This section is designed to show you how to get MPIRE up and running, render an image, change the view, save an image, and exit using the Java applet interface. Details regarding the individual parameter controls can be found in MPIRE Interface Parameters Reference .

Starting MPIRE

The process of rendering an image of volume data using the MPIRE java applet interface is as follows.

Running renderd

Log onto the desired render host and determine if at least one copy of renderd is already running. If it isn't then go to the directory containing the executable and type "renderd &". As long as at least one copy of the daemon is running, any number of users will have access to the MPIRE rendering engines installed on that system.

Running an HTTPD Server

The HTML file from which the MPIRE java applet is run can be loaded either as a local file or downloaded from a web server running on the host where the rendering engine will be run. An HTTPD server is only needed in the latter case. Check with the system administrator of the host on which you wish to render to determine if an HTTPD server is already available.

Loading the MPIRE Java Applet

The MPIRE applet ties together a number of custom, object oriented classes, written in the Java programming language. The applet is loaded and run through a Java capable web browser in just the same way that other Java applets are used. The HTML file from which the MPIRE applet is run can be loaded either as a local file or downloaded from a web server.

The first method involves storing the applet and HTML page on the interface host (the system where the applet will be run). The applet is loaded in this configuration by opening the web page using the file HTTPD tag (as opposed to the http tag). Most web browsers provide an Open File option under their File menus for this purpose.

The second method involves storing the applet and HTML page on the render host (the system where the rendering will take place). Once a web server is running on that host, the applet is loaded by opening the HTML page from that host as you would open any other remote web page. Most web browsers provide an Open Location option under their File menus for this purpose.

Using either method, after the web page has loaded, select the Start an MPIRE button. After a few seconds the main MPIRE applet window (shown smaller than actual size below) should appear.


Rendering an Image

Once the MPIRE applet has been loaded, rendering an image involves entering the appropriate parameter values, selecting a rendering engine, and pressing the render button.

Entering Rendering Parameters

Due to security restrictions imposed on the execution of java applets by the web browser, the MPIRE applet cannot read parameter settings from a local file at this time. So to specify a set of resource and rendering parameters, simply set the values of the corresponding widgets in the applet appropriately. Generally, a complete set of parameters have been specified when the values under the option panels are filled out, and a materials file (located on the render host) has been specified under the File menu. Please refer to the MPIRE Interface Parameters Reference section for details regarding individual parameter settings.

Starting an Engine

A rendering engine can be started on the render host at any time before or during the entry of the other rendering parameters. Note however that an engine must be started prior to rendering an image.

To start a renderer, go to the Resources panel under the Options menu. Enter suitable values for the rendering host, port, and nodes parameters. As with all text widgets in Java applets, be sure to press the Enter or Return key after entering a value. Next select an MPIRE renderer from the rendering engine choice list. Note that not all choices may be available for the type of rendering host you have selected. Please refer to System Requirements for information regarding which engines are available for your rendering platform of choice. Select the start engine button to initiate the specified engine on the desired host, and cause a status message indicating successful startup to appear in the status window (this window is opened by selecting the show status window button under the status options panel). Note that the MPIRE applet may pause if the necessary compute resources are not available at request time. As these resources become available, the applet will continue.

Rendering

Once the rendering parameters have been specified and a rendering engine is running, press the render button located at the bottom of any of Options panels to generate an image. You can track the progress of the rendering by watching the messages that appear in the status window. Note that the rendering process is composed of three steps including shading, rendering, and compositing. The first of these includes the process of reading your data from disk and requires the most time (perhaps a few minutes depending on the size of the dataset). However this step is only executed when changes are made to parameters describing characteristics of the raw data, and the position of the light source. All other changes result only in the execution of the rendering and compositing steps, and should require no more than a few seconds for the generation of an updated image.


Changing the View

The MPIRE applet allows you to manipulate your view of the volume by using the mouse to control a virtual trackball. Note that the following directions assume that the auto render option is set under the Prefs menu (any changes to the trackball will cause an updated image to be automatically rendered by the engine).

With the mouse pointer in the main MPIRE applet window, press and hold the left mouse button. Doing so will display a bounding box superimposed over the rendered image. You can rotate the bounding box by moving the mouse. Once you have achieved the desired rotation, release the mouse button and a new image will be rendered based on the updated view. You can translate the bounding box (and hence the volume) by moving the mouse pointer in the image window with the right mouse button depressed. You can scale the bounding box by moving the mouse pointer in the image window with the middle mouse button depressed. If you are using a one or two button mouse, rotate the box using the left (or only) button, scale the box using the left (or only) button while pressing the Alt key, and translate the box using the left (or only) button while pressing the Meta or key. Finally, you can reset the view to the default by pressing the reset camera view button on the image options panel.


Exiting MPIRE

After you have finished your rendering session, you can exit from the MPIRE applet by first closing down the rendering engine and then quitting the applet. To shut down the engine, select the stop engine button on the resources options panel. To exit from the applet, simply select the Exit option from under the File menu.


CONTENTS * ABOUT * AVS INTRO * JAVA INTRO * PARAMETERS * APPENDIX